Issues with reporting in AStRA

Incident Report for Prifysgol Aberystwyth University

Resolved

Issues with reporting in AStRA have now been resolved.
Posted Jul 21, 2025 - 15:31 BST

Investigating

We are currently investigating issues with generating reports in AStRA.
Posted Jul 21, 2025 - 10:57 BST
This incident affected: Business Systems (AStRA).